Versions

Nov 24, 2008 at 1:46 PM
Folks,
Excited about this potential of this product but is there version that works with VS2005 .net 2.5/3?

Thanks
Developer
Nov 24, 2008 at 2:53 PM
Hi

What kind of target do you have in mind with that? The current tool is built against the .NET 3.5 Framework but supports the reverse enginering of an application built on any version of .NET. So IMHO the only requirement to have the .NET 3.5 framework lies in the use of the tool itself. You do not need to have VS2008 to work with the tool, only when you want to go through the source code.

Thanks,
Meile
Nov 24, 2008 at 3:25 PM
Edited Nov 24, 2008 at 4:55 PM
Hi and thanks for the reply on that. Problem I get is this.....

[Please describe what might have caused this error.]

Could not load file or assembly 'System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The system cannot find the file specified.

System.IO.FileNotFoundException

   at Reflector.Sequence.Rules.IsValidCall(Object insOperand)
   at Reflector.Sequence.MethodData.AddNewCall(String typeName, IMethodDeclaration methodDefinition, Object callDefinition, String startMethod) in E:\Code\LiveSequence\Src\trunk\LiveSequence.Reflector\MethodData.cs:line 49
   at Reflector.Sequence.InstructionDataPopulator.ParseMethodBody(ITypeReference typeReference, IMethodDeclaration method, String startMethod) in E:\Code\LiveSequence\Src\trunk\LiveSequence.Reflector\InstructionDataPopulator.cs:line 138
   at Reflector.Sequence.InstructionDataPopulator.BuildGraphFromMethod(IMethodDeclaration method) in E:\Code\LiveSequence\Src\trunk\LiveSequence.Reflector\InstructionDataPopulator.cs:line 60
   at Reflector.Sequence.DiagramViewerContainer.Translate() in E:\Code\LiveSequence\Src\trunk\LiveSequence.Reflector\DiagramViewerContainer.cs:line 85
   at Reflector.Sequence.DiagramViewerContainer.OnParentChanged(EventArgs e) in E:\Code\LiveSequence\Src\trunk\LiveSequence.Reflector\DiagramViewerContainer.cs:line 50
   at System.Windows.Forms.Control.AssignParent(Control value)
   at System.Windows.Forms.Control.ControlCollection.Add(Control value)
   at System.Windows.Forms.Control.ControlCollection.AddRange(Control[] controls)
   at ᝊ.ᜀ()
   at ᝊ.ᜀ(IWindow A_0)
   at ឨ.ᜁ(String A_0)
   at ឨ.ᜀ.ᜀ(Boolean A_0)
   at Reflector.Sequence.OpenSequencePackage.OnOpenSequenceClick(Object sender, EventArgs e) in E:\Code\LiveSequence\Src\trunk\LiveSequence.Reflector\OpenSequencePackage.cs:line 72
   at ᝸.ᜆ.ᜀ(EventArgs A_0)
   at ᝸.ᜆ.ᜃ()
   at ᝸.ᜅ.ᜀ.ᜂ(EventArgs A_0)
   at System.Windows.Forms.MenuItem.MenuItemData.Execute()
   at System.Windows.Forms.Command.Invoke()
   at System.Windows.Forms.Command.DispatchID(Int32 id)
   at System.Windows.Forms.Control.WmCommand(Message& m)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.TreeView.WndProc(Message& m)
   at ᝈ.ᜀ(Message& A_0)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

.NET Reflector 5.1.4.0
.NET Framework 2.0.50727.832
Microsoft Windows NT 5.1.2600 Service Pack 2
Culture: en-US (en-IE)

[AddInManager]
"C:\!Programming\Tools\Reflector\Reflector.LiveSequence.dll"

 

Nov 24, 2008 at 4:56 PM
Re-reading your replay. Yes, I want to use the tool in an environment that does not have 3.5 installed. Is there a compatible version for 3 or 2.5?

Thanks again
Nov 25, 2008 at 11:45 AM
Just to update: I got this working by actually installing 3.5.

Now, I'd love to know why i can't (or how do I) create a sequence diagram that could be loaded into Visio for editing/trimming? Is that possible?


Absolutely love this tool though I have to say.
Nov 25, 2008 at 1:46 PM
Answering my own questions....opening in visio2007 is possible using the save as .xps option. Unforuntately I have only 2003.